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Introduction 
As the amount of observation data captured everyday increases, running scientific workflows 
will soon become a fundamental step of scientific inquiry. Current scientific workflow 
systems offer ways to link together data, software and computational resources, but often 
accomplish this by requiring a deep understanding of the system with a steep learning curve.  
Thus, there is a need to lower user adoption barriers for workflow systems and improve the 
plug-and-play functionality of these systems which drove our development of 
Cyberintegrator1. 

Cyberintegrator is a user friendly editor to several middleware software components that (1) 
enable users to easily include tools and data sets into a software/data unifying environment, (2) 
annotate data, tools and workflows with metadata, (3) visualize data and metadata, (4) share 
data and tools using local and remote context repository, (5) execute step-by-step workflows 
during scientific explorations, and (6) gather provenance information about tool executions 
and data creations.  

The middleware software components interfaced by Cyberintegrator editor are (a) multiple 
plug-in codes called executors for running external tools, Matlab scripts and java codes, (b) 
Tupelo data and metadata archiving system based on the Resource Description Framework 
(RDF) metadata model, and (c) portal systems (currently Cybercollaboratory based on Liferay 
portal technology).  

The Cyberintegrator editor is built on top of the eclipse rich client platform (RCP) to achieve 
its full functionality of re-configurable user interface and plug-and-play architecture critical for 
easy deployment of the Cyberintegrator application. The ultimate goals of Cyberintegrator are 
to support scientific discoveries and to provide means for conducting research more 
efficiently.  

Background  

The functionality of Cyberintegrator that allows linking software tools is similar to a workflow 
system. Current paradigms for workflow creation focus on the visual programming using a 
graph based metaphor. This can be a powerful metaphor in the hands of expert users, but can 
become daunting when graphs become large, the steps in the graph include engineering level 
steps such as loading and visualizing data, and the users are not very familiar with all the 
possible tools available. Cyberintegrator presents a different method of workflow creation that 
co-exists with the standard graph based editors. The method builds on exploratory interface 
using a macro-recording style, and focuses on the data being analyzed during the step by step 
creation of the workflow. 

Instead of storing data in system specific data structures, the use of more flexible open 
standards that are platform independent would create systems that are easier to extend and that 
                                                 
1  More information about Cyberintegrator project can be found at 
http://isda.ncsa.uiuc.edu/software.html 



 

provide a simple interface for external applications to query and analyze the data and metadata 
produced. We have implemented Cyberintegrator that stores workflows and related metadata 
using the Resource Description Framework (RDF) metadata model. It is build on top of the 
Tupelo, Sesame and WebDAV technologies. Tupelo is a data and metadata archiving system. 
Sesame is a computing infrastructure designed to support secure interactions among the client, 
server, and database tiers, and application modules that carry out specific tasks. WebDAV is 
Web-based Distributed Authoring and Versioning software for editing and managing files 
collaboratively on remote World Wide Web servers. Cyberintegrator connects to content 
repositories (local or remote), where users can easily share data, workflows, algorithms and 
annotations. 

In comparison with Cyberintegrator version 1, this version 2 is built on top of a Rich 
Client Platform (RCP) technology. A Rich Client Platform (RCP) could be viewed as a 
computer program designed for the creation of applications written in Java and built on 
the Eclipse architecture. Eclipse is an Integrated Development Environment (IDE) that is 
open source and developed by the on-going Eclipse project members2 and by the Apache 
Software Foundation.3  Applications written using RCP are portable and the plug-ins can be 
reused and mixed.  
 
From this perspective, the Cyberintegrator version 1 was lacking and hence the redesign 
leading to version 2. The Cyberintegrator version 2 can now support constantly changing 
requirements of a typical exploratory science. The RCP platform is also ideal for (1) 
accommodating user-driven customizations of graphical user interfaces (GUI) of the 
workflow editor, (2) adding new features to the workflow environments in run-time and 
(3) deploying Cyberintegrator on multiple platforms and with modules/components 
custom-selected by the end users of the workflow system.  

1.1 Main Cyberintegrator Functionality 
 

The key functionalities of the current implementation of Cyberintegrator can be summarized 
as follows.  

(1) It enables users to easily include tools and data sets into a software/data unifying 
environment. 

(2) Cyberintegrator comes with a set of functionality for visualizing text/ASCII and image 
data, as well as metadata and annotations about data.  

(3) It enables users to annotate data, tools and workflows with metadata. 

(4) Cyberintegrator allows sharing data and tools using local and remote context repository,  

(5) It enables scientific explorations by step-by-step execution of workflows. 

                                                 
2  http://www.eclipse.org/membership/exploreMembership.php 
3  http://www.apache.org/ 



 

(6) Cyberintegrator gathers metadata information about imported tools and data, as well as 
about tool executions and data creations.  

 

1.2 Cyberintegrator User Interface 
 

The graphical user interface (GUI) of Cyberintegrator consists of views (or windows 
displaying certain information about data, tools or status) and perspectives (a collection of 
views). One perspective (GUI configuration) of the Cyberintegrator editor is shown in Figure 
1.  

 

Figure 1.  A set of views creating a perspective. The views display imported data sets (left upper 
corner), tools (left middle), a set views corresponding to the workflow, workflow graph, step creator 
and error log (bottom) and metadata information view (right large pane). 
 

Views and perspectives can be manipulated (create, open, close, save, reset) from the main 
menu (see Figure 2). Each view could be maximized by double clicking on the view tab and 
restored by double-clicking the view tab again. Views can be reconfigured by dragging and 
resizing each view window. Several example perspectives and views are illustrated in Figure 
4, Figure 5 and Figure 6. 



 

When a set of views was customized then it could be saved by selecting “main->window-
>save perspective as”. The same perspective could be opened by selecting one of the saved 
perspectives in the dialog launched by “main->window->open perspective->other” (see Figure 
3)  There are 3 preset perspectives (Cyberintegrator, Repository Exploration, and Workflow 
Execution) that come standard with the Cyberintegrator package, as shown below.  

  

 

 

Figure 2.  Accessing perspectives (top) and views (bottom) via the main menu->window options.  



 

 

 

Figure 3.  Open perspective by selecting one of the saved perspectives in the dialog launched 
by “main->window->open perspective->other”. 

 

Figure 4. An example of a perspective with the list of data sets (left upper view), the list of tools (left 
lower view), visualization of the content of the Wind Direction data set (right view) and the 
annotation panel for describing the workflow and creating metadata about the workflow (bottom 
view). 
 



 

 

Figure 5. An example of a perspective with the list of data sets (left view), the visualization of 
metadata about the data set called SWMMORGN.INP (right view) and the visualization (a workflow 
graph) of all activities (bottom view). 
 



 

 
Figure 6. An example of a perspective with visualizations of metadata about the tool called paretosol 
(top view) and a workflow graph of all activities (bottom view). 
 

1.3 Preferences 
Properties of Cyberintegrator can be accessed and modified by selecting main->window-
preferences. There are properties related to  

• editable metadata entries in attribute editor  
• authentication information for logins 
• additional views visualizing metadata and attributes 
• information for connecting to a Liferay-based portal system at NCSA 
• log settings during Cyberintegrator executions 
• settings for browsing context 
• local and remote storage of context 
• visualization of user actions in the view displaying a workflow graph. 

 
 
 
These properties are explained in Figure 7 through Figure 13. 
 
 
 
 



 

 
 
Figure 7.  Preference page related to the form of authentication. If “Context Login” 
would be selected then a user can register and authenticate later using his/her user 
identification (ID) and password when working with Cyberintegrator. The user ID 
replaces the anonymous default creator and is used when the work in Cyberintegrator is 
performed (e.g., creation of workflows, data sets, tools or annotations). If “Liferay” is 
selected then the authentication is performed against the user ID and password in the 
NCSA CyberCollaboratory.4  
 

                                                 
4  http://cleaner.ncsa.uiuc.edu/cybercollab/c/portal/layout?p_l_id=1.1 



 

 
Figure 8.  Preference page containing authentication information to connect to a Liferay-
based portal system at NCSA called Cybercollaboratory.5 
.  
 
 
 

                                                 
5  http://cleaner.ncsa.uiuc.edu/cybercollab/c/portal/layout?p_l_id=1.1 



 

 
Figure 9.  Preference page that allows (a) hiding or showing (check box labeled as 
“Workflow Graph” is checked by default) user actions, such as import data/tools or 
preview data, in the view displaying a workflow graph, (b) using previews of large files 
(the “Use preview” checkbox) and (c) adding two extra views to the collection of all 
available views. The Tupelo view is shown in Figure 5. 
 
 
 



 

 
Figure 10. Preference page related to editable metadata entries. The “Show Attribute” 
checkbox refers to the Attribute View and the visibility of attributes. The list of entries 
under the label “list of predicates that cane be modified” refers to those predicates in the 
RDF triples (subject-predicate-object) that are enabled for editing. We do not recommend 
adding additional editable predicates! 
 
 



 

 
Figure 11. Preference page for selecting different levels of logging, along with the global 
log level. Within this subtree, you can select different types of logging, such as Console 
logging, Eclipse logging, Log4J logging, and Popup logging. Each has its own 
preferences that you can customize to your liking.  
 
 



 

 
Figure 12.  Preference page related to browsing the context (metadata). The settings 
define the appearance of the graph visualizing the metadata retrieved from Tupelo. 
Layout – automatic layout of the graph. Depth – how many layers deep the sub-nodes 
should be shown. Direction – filters graph showing only sub-nodes that contain selected 
directions Subject->Predicate->Object of the predicates. 
 
 



 

  
 

  
Figure 13.  Preference page with the four tabs related to local and remote storage of 
metadata. The current setting in the top left screen is for local context. The location of the 
local context is defined in the second tab (top right). In the first tab (top left), the 
checkboxes “WebDAV/Sesame Context” and “mySQL Context” should be checked 
when the end product of the work in Cyberintegrator should be shared with a community. 
In the current prototype, Sesame is the computing infrastructure supporting secure 
interactions among the client (Cyberintegrator user), NCSA server, and NCSA database 
tiers. WebDAV is the Web-based Distributed Authoring and Versioning software 
managing metadata information on remote servers. 
 
 
 
 



 

Chapter 2  - Getting Started 
 

2.1 New Workflow and Login 
After starting Cyberintegrator, one can start with creating a new workflow and logging into 
the system if needed. 

(1) Starting a new workflow 

Select File->New->Workflow from the main menu. A new dialog will appear as shown 
in Figure 14. The title (name) of the workflow will be associated with all activities in 
Cyberintegrator. Figure 15 shows the appearance of Cyberintegrator after creating a new 
workflow. 
 

 
Figure 14.  A dialog invoked by File->New->Workflow that allows starting a new 
workflow. 
 
 



 

 
Figure 15.  Cyberintegrator appearance after creating a new workflow. 
 
(2) Logging as a known user. 
When Cyberintegrator is started, the user name is automatically set to anonymous. If a 
user would like to use his/her known login then the login can take place in two ways. The 
first way is based on an already existing user login in the NCSA Liferay based portal 
system called Cybercollaboratory. The second one is based on a local context where a 
user account is created specifically for Cyberintegrator login. The Liferay or local context 
type of login is defined in the authentication preference dialogs, accessible by going to 
Window >> Preferences in the main Cyberintegrator window.  
 
Depending on the authentication preference dialog, a login dialog is invoked by clicking 
on the “Login” button in the top left corner of Cyberintegrator right below the File menu. 
One can then login by authenticating against the Liferay based portal (see Figure 16 (top) 
or against the local context (see Figure 16 (bottom). 
 



 

 

 
Figure 16.  Based on the settings for authentication shown in  
 
 
 
Figure 7, a user login is enabled either via Liferay (top) or the local context (bottom). The 
appropriate dialog is invoked by clicking on the “Login” button in the top left corner of 
Cyberintegrator right below the File menu. A new Liferay account can be created at the 
NCSA CyberCollaboratory web page. A new local context account is created by pressing 
the button “Register” (bottom figure). A user will see his/her user ID by viewing the 
Workflow View (previously anonymous).   
 
 

2.2 Importing and Exporting Data, Existing Tools and 
Workflows 

Cyberintegrator enables users to easily import and export existing data, workflows and tools 
into and from a software/data unifying environment.  

(1) Importing Data: 

Importing data can be performed by either dragging followed by dropping the data files into 
the data pane (see Figure 18) or by selecting File->Import followed by the choices shown in 
Figure 17. In both cases, the mime6 type of data can be determined automatically based on the 
                                                 
6  From Wikipedia: “Multipurpose Internet Mail Extensions (MIME) is an 
Internet Standard that extends the format of e-mail to support: 



 

suffix of the data files. For example, JPG or TIF suffix will indicate image mime types while 
TXT or CSV would indicate plain/text types. Application/octet-stream should be used for 
application (binary) data types. When a user chooses the drag/drop option for importing data 
files then the data mime type will be determined automatically by default and if the mime type 
could not be determined then a dialog will be shown. If a data set contains metadata about the 
type, select the “Data including metadata” option. Otherwise, you can select the “Data no 
metadata” option and specify the type yourself.  

 

  

Figure 17. The dialog for importing data, workflows or tools.  
 
If a data file imported is larger than a pre-set file size threshold then a preview will be 
automatically created. Figure 18 illustrates this example when the selected image is 
imported and a preview can be viewed immediately.  

                                                                                                                                                 
•  text in character sets other than US-ASCII;  
•  non-text attachments;  
•  multi-part message bodies; and  
•  header information in non-ASCII character sets. “. All media mime types 

can be found at http://www.iana.org/assignments/media-types/. 

 



 

 
Figure 18.  Example of importing data. Importing a land use/land cover map to the data 
pane, selecting the preview image for viewing in the right pane and viewing the 
workflow graph of activities in the bottom pane. 
 
(2) Exporting Data: 
 
The export of any data file is enabled (a) by File->Export menu (see Figure 19), (b) by 
right mouse click on the data file and selecting the export option (Figure 20) or (c) by 
dragging and dropping the file to a File explorer. 



 

 
Figure 19.  Example of exporting data using the right mouse click on the data file.  
 

  

Figure 20.  Example of exporting data using the File->Export option. 

(3) Importing Existing Tools: 



 

Tools are viewed as a “black box” with inputs, outputs and parameters. This model is used for 
creating xml descriptions of tools. Two examples of xml descriptions of tools are provided in 
Figure 21. 

 

 

Figure 21.  Two examples of XML files that represent a Notepad tool (top) and SWMM tool 
(bottom). The Notepad tool take original text, opens the text in Notepad and then saves out the 
modified text. The SWMM tool encapsulates the Storm Water Management Model (SWMM), 
its inputs and outputs. 



 

In order to create tools that could be executed in Cyberintegrator, one has to create the xml 
description. We will explain later how these xml descriptions can be created using wizards. 

Assuming that there are exist tools (xml files describing tools); one can import the tools by 
either dragging followed by dropping the xml files into the tool pane (see Figure 23) or by 
selecting File->Import followed by the choices shown in Figure 22 

  

Figure 22.  Example of importing tools by invoking dialogs via File->Import. 



 

 

Figure 23.  Example of importing the tool called Notepad. 

(4) Exporting Tools: 

The export of any tool is enabled (a) by File->Export menu (see Figure 24), (b) by right 
mouse click on the tool and selecting the export option or (c) by dragging and dropping 
the file to a File explorer. 
 



 

  

Figure 24.  Example of exporting tools by invoking dialogs via File->Export. 

(5) Importing and Exporting Existing Workflows: 

Importing and exporting workflows is described in Figure 25 and Figure 26. 

  

Figure 25.  Example of exporting workflow by invoking dialogs via File->Export. 

 



 

  

Figure 26.  Example of exporting workflow by invoking dialogs via File->Export. 

 

2.3 Viewing and Annotating Data, Tools and Workflows 
 

Cyberintegrator comes with a set of functionality for visualizing text/ASCII and image data, 
as well as metadata and annotations about data. In addition, data, tools and workflows can be 
annotated with unstructured text or text following the RDF metadata format. 

(1) Viewing Image and Text/Plain Data: 

Once a data set has been imported, it can be viewed by right mouse clicking on the data in the 
data pane and selecting “Open in New Window” (see Figure 27). Multiple viewers and 
viewing options can be accessed from the right upper corner of the window. Figure 28 shows 
the options for image data and Figure 29 shows the options for text/plain data. 



 

 

Figure 27.  A data file can be viewed by right mouse clicking and selecting the option “Open 
in New Window”.  



 

 

Figure 28.  An image data viewer can show either the original image or the preview image. 
The setting for image viewers can be accessed by left mouse clicking on the triangular shape 
pointing downward in the right upper corner of the visualization window as illustrated here. 



 

 

Figure 29.  A text/plain data viewer can show either the original text or the preview text (top 
lines only). The setting for text/plain viewers can be accessed by left mouse clicking on the 
triangular shape pointing downward in the right upper corner of the visualization window as 
illustrated here. 

 
(2) Viewing Metadata: 

There are several views of metadata that are either enabled by the default perspective or 
can be enabled by selecting from the main menu Window->Show View.  One can see the 
textual or graph views in Figure 30 through Figure 33. 



 

 
Figure 30.  An attribute view (right window) of the metadata about an imported image 
cat.gif. 



 

 
Figure 31.  A graph view called Tupelo View (right window) of the metadata about an 
imported image cat.gif. 
 
 
Figure 32.  A graph view called Tupelo browser (bottom window) of the metadata about 
all workflow activities. 



 

 
Figure 33.  An information view (right window) of the inputs, outputs, parameters and 
any other information (metadata) about the tool called Notepad. Very similar information 
is provided in the bottom window in the Step Creator view. The Step Creator view is for 
executing the tool/step. 
 
(3) Adding Annotations: 

Annotations can be added to data, tools or workflows. Furthermore, the workflow 
description can be also added as shown and explained in Figure 34.  
 
 



 

 
Figure 34.  A new annotation is added by selecting a data set, a tool or a workflow and 
clicking the button “New Annotations”. When the text is completed the button “Submit” 
should be clicked. 
 
 
(4) Sorting Data and Tools: 

Many times the number of data sets and tools might be very large and there is a need to 
search for the data and tools of interest. This can be accomplished by filtering data based 
on tags, names or types as illustrated in Figure 35. 
 



 

 
Figure 35.  Sorting/Filtering of data sets can be accomplished by right mouse clicking on 
the triangular icon in the upper right corner of the Data view and selecting one of the 
options. The same filtering can be applied in the Tools view.  
 
In order to assign tags to data or tools, one has to select a data/tool and press ALT-T. 
 

 
Figure 36.  The dialog invoked after selecting a data set or a tool and pressing ALT-T. 
The tag will be used for sorting the files. 
 
 
 
 



 

Note: It is advised to start a new workflow after very many analyses have been completed 
otherwise rendering of a large collection of activities might be time consuming. See the 
complexity of the graph rendered in Figure 37. 

 

Figure 37. Visualization of a very large set of analyses in one workflow set that might take significant 
computational resources for rendering. It is advised to create a set of independent workflows to avoid 
slow rendering. 
   

2.4 Creating a Tool  
There are several types of desktop applications, remote functionalities accessible via web 
services or library codes written in multiple languages that might become tools. In 
Cyberintegrator, they are all defined by their inputs, outputs, parameters and executables with 
the appropriate libraries. The challenge of creating a tool in Cyberintegrator is to simplify the 
tool creation for a novice. 

In order to make the tool creation in Cyberintegrator easer for users, Cyberintegrator provides 
multiple wizards for tool creation. The wizards are accessible from the main menu File->New 
as illustrated in Figure 38.  



 

 

Figure 38. Tool creation using wizards can be invoked from File->New as illustrated above. 

Cyberintegrator version 2 has a rather expansive array of wizards to assist the end user in tool 
creation. The Command Line Tool wizard is for creating tools based on executable files that 
could have been run in a command line or a shell. The Java tool wizard is meant for creating 
tools by interfacing application programming interface of methods written in Java and 
available in jar files. Finally, a Matlab tool wizard is built for creating tools that are actually 
Matlab scripts (.m files).  

It is possible to create tools for many other codes and software functionalities by creating xml 
descriptions of each specific tool. We can provide the xml schema for creating tools for 
computer savvy users. If communities would request wizards for a group of tools, for instance, 
tools created from GRASS package, then we might build additional wizards.   

 

(1) Creating Command Line Tools 

For this example, we will try to create a tool that provides directory listing given a directory 
location. The functionality can be tested by opening a cmd window by selecting Start->Run 
(on Windows machines), typing “cmd” and then typing “dir” in the cmd window. The result is 
the directory listing in the cmd window. The directory listing tool is a sequence of “cmd” and 
“dir” in the cmd window. The input is a string (text/plain) defining the directory location. The 
output is the text/plain that is generated in the cmd window. 

 



 

To build the directory listing tool, start with the sequence File->New->External Tool Wizard. 
Figure 39 shows the first dialog that is designed for inserting a general description of the tool. 
Figure 40 through Figure 46 illustrate the meaning of the entries in each wizard dialog and 
how to populate them when the directory listing tool is created. 
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Figure 40. The second wizard dialog for entering the executable and its parameters, inputs and 
outputs. The entry next to the label “Executable” refers to the name of the executable. If the 
“Exitcode” labeled check box is checked then the exit code will be verified to determine 
whether the application successfully completed its run or failed. The “Capture stdout” labeled 
check box is for enabling to pipe the output of execution in the execution window to a file.  
The buttons labeled as “New Value”, “New Parameter”, “New Input” and “New Output” are 
for inserting information about (a) the sequence of execution commands, (b) 
variables/parameters of the execution that should be directly modified before each run from 
Cyberintegrator, (c) inputs coming from data files already in Cyberintegrator or residing on 
disk, and (d) outputs generated by each run in the execution window or directly saved to a 
disk. 

 



 

 

Figure 41. The dialog invoked from the second dialog shown in Figure 40 by clicking on the 
button “New Value”. The entries correspond to the cmd command line options (cmd /C dir).  

 

Figure 42. The dialog invoked from the second dialog shown in Figure 40 by clicking on the 
button “New Parameter”. The entries correspond to the directory (value is set to C::\temp) that 
would be listed by default and is defined by a string that is passed to the command line. 

 

 

 



 

Figure 43. The dialog invoked from the second dialog shown in Figure 40 by checking the 
check box “Capture stdout?” and clicking on the button next to the check box. The entries 
correspond to the name, description and type of the output gathered by piping the text 
generated by “cmd /C dir” to a data set placed in the data pane of Cyberintegrator. 

 

Figure 44. The third wizard dialog designed for adding external resources. For example, if an 
executable would depend on a set of dlls or jar files then one would click the button “Add” 
and select all additional files needed for the successful execution of the main executable. All 
external resources become parts of the context that is stored with the tool. If the tool would be 
shared then anyone might receive the tool with all external resources and run it assuming 
platform compatibility.  



 

 

Figure 45. The fourth wizard dialog provided for creating environment variables needed to 
find external resources. For example, if an executable would depend on external resources that 
have to be specified by global environment variables then the variables could be set before the 
tool is executed.  



 

 

 

Figure 46. Snapshots of Cyberintegrator after the directory listing tool was created (see the 
tool pane) and executed. The execution is accomplished by double clicking on the tool, 
specifying the name of the parameter (directory location) in the bottom pane and pressing the 
button “Execute Step” in the lower left part of the Step Creator window. After the step is 
completed, the data pane will show a new file called “cmd dir output [DONE]” while during 
the execution it would show “cmd dir output [RUN]”. If the execution fails then it would be 
denoted by [FAIL]. The icons left to the name of the output also differ based on the status of 



 

the execution.  The top figure is obtained by right mouse clicking on the data set and selecting 
“Open in New Window”. The right window (top figure) shows the directory listing for the 
C:\temp directory. The bottom figure is obtained by selecting the Tupelo View and it 
illustrates all metadata about the data set that was just created. 

  

(2) Additional dialogs of interest: 

There are several dialogs that have not been covered in the previous example and might be of 
potential interest to users. Two additional dialogs and their entries are described in Figure 47 
and Figure 48. 

  

Figure 47. The dialog invoked from the fourth wizard dialog shown in Figure 45 by clicking 
on the button “New”. The entries correspond to the name of the environment variable and its 
value as illustrated for the case of setting the JAVA_PATH variable to point to the installation 
of java 1.6. 

 

 

Figure 48. The dialog invoked from the second dialog shown in Figure 40 by clicking on the 
button “Output Data”. The flag entry is designed for inserting any flags that would precede the 
name of the output file and would be parsed by the executable. The Filename checkbox and 
entry is for those executables that would have hard coded names of output files and we would 
them to be in the data pane after finishing the execution. The button next to the “Output” label 



 

is invoking another dialog that allows describing output data placed in the data pane of 
Cyberintegrator immediately after launching the tool. The invoked dialog is identical with the 
dialog in Figure 43. 

(3) Linking Tools: 

In many cases, the tools have to be linked together the same way as scripts are created by 
forming a sequence of executions of multiple tools. In Cyberintegrator, linking can be 
accomplished by selecting a tool and passing the outputs of the previously executed tool to it. 
For instance, if the output of the directory listing tool would be passed to the Notepad tool 
then the output of the directory listing tool becomes the input to the Notepad tool.  The linking 
is illustrated in Figure 49, Figure 50 and Figure 51. Figure 52 shows how to tag and sort 
resulting outputs. 

 

Figure 49. Execution of the Notepad tool with input equal to the output from the directory 
listing tool. The Notepad tool is double clicked first in the Tool view. Then, the input file is 
selected to be the cmd dir output file in the Step Create View. The output of the notepad tool is 
denoted as cmd dir notepad output. Finally, the Notepad tool is executed by clicking on the 
“Execute Step” button. 

 



 

 

Figure 50. The directory listing followed by the Notepad tool execution leads to showing the 
directory listing in Notepad. 

 

Figure 51. The workflow graph of the directory listing followed by the Notepad tool 
execution. (bottom pane) 

 



 

 

 

Figure 52. Tagging data sets by CMD and Notepad tags allows sorting large collections of 
data sets. Tagging is enabled via the dialog (top figure) invoked by the combination of keys 
“ALT” and “T”. Sorting is enabled via the “Sort by Tag” selection from the upper right corner 
of the Data view (the triangular shape icon) invoked by right mouse clicking. The result of 
sorting by tags is shown in the bottom figure. 



 

Appendix ASoftware License 
 

The software is owned by the University of Illinois at Urbana-Champaign and the appropriate 
licensing mechanism is currently under review.  



 

Appendix BKnown Issues 
 

There is a list of known issues with the current alpha release that are recorded in the NCSA 
JIRA system at  

http://torcida.ncsa.uiuc.edu:8080/jira/secure/IssueNavigator.jspa?reset=true&mode=hide&sort
er/order=DESC&sorter/field=priority&resolution=-1&pid=10052&fixfor=10046 

JIRA is a bug tracking application where the development team and the users and testers can 
report software bugs. One can monitor the progress of the Cyberintegrator project by going to 
the NCSA JIRA web site at http://torcida.ncsa.uiuc.edu:8080/jira/browse/CBI. This site 
should be also used for filing a new software bug as illustrated in Figure 53. 

 

Figure 53.  The NCSA JIRA web page for Cyberintegrator at 
http://torcida.ncsa.uiuc.edu:8080/jira/browse. One can report a bug by clicking on the “create new 
issue” tab. and proceeding through a set of windows to describe the software bug. 
 

 


